Zmiana zapisu wartości liczbowej na zapis słowny Przeznaczenie I budowa skoroszytu




Pobierz 129.99 Kb.
NazwaZmiana zapisu wartości liczbowej na zapis słowny Przeznaczenie I budowa skoroszytu
Data konwersji13.12.2012
Rozmiar129.99 Kb.
TypDokumentacja

Część I


Arkusz „słownie” opracowaliśmy wspólnie na zajęciach laboratoryjnych, zatem poniższy materiał stanowić powinien dla Państwa jedynie wsparcie w czasie pracy nad pozostałymi arkuszami projektu ewentualnie stanowić uzupełnienie służące lepszemu zrozumieniu funkcjonowania arkusza „słownie”.

Zmiana zapisu wartości liczbowej na zapis słowny

Przeznaczenie i budowa skoroszytu


Często zachodzi potrzeba zapisu wyrażenia liczbowego w postaci słownej, np. przy wystawianiu faktury. W naszym przypadku zapis słowny będzie miał postać:

cyfra*cyfra*cyfra*cyfra*cyfrd*cyfra*cyfra*cyfra*liczba_groszy/100zł

gdzie:

cyfra* — oznacza kolejną cyfrę w wartości zapisaną słownie, np. siedem*,

liczba_groszy — wyrażenie liczbowe części dziesiętnych wartości, np. 23,

/lOOzł — stała tekstowa.

Skoroszyt składa się z dwóch arkuszy kalkulacyjnych:

  1. Arkusz l — arkusz główny, w którym chcemy pokazać wartość numeryczną za pomocą zapisu słownego.

  2. Słowo — arkusz dokonujący faktycznej zamiany zapisu.

Obsługa arkusza


Arkusz Słownie

Arkusz (rysunek 1) tworzymy według poniższych kroków:

1. W komórkach od Al doAl0 należy umieścić kolejno zapis słowny cyfr od O do 9, umieszczając na końcu każdego słowa znak gwiazdki (*).

2. Do komórki C8 wprowadzać będziemy wartość poddawaną zamianie. W naszym przypadku jest to wartość komórki L42, znajdująca się w arkuszu Faktura, stąd też formuła zawarta w niej ma postać =FAKTURA!L42. Format komórki C8 posiada kategorię Liczbowe z dwoma miejscami po przecinku.

3. W komórce C9 wpisujemy formułę =LICZBA.CAŁK(C8), co spowoduje pokazanie się w niej tylko części całkowitej liczby z komórki C8. Format komórki C9 posiada kategorię Ogólne.

4. W komórce D9 umieszczamy formułę w postaci =(C8-C9)*100 co pozwala na uzyskanie, jako wartości całkowitej, części dziesiętnej liczby z komórki C8. Format komórki D9 posiada kategorię Ogólne.




Rysunek 1. Arkusz Słownie


5. W komórce E9 umieszczamy formułę =TEKST(D9;0)&"/100zł", powodującą zamianę zawartości komórki D9 na tekst i dodanie do niej stałego wyrażenia tekstowego "/lOOzł". Sumowanie tekstów odbywa się za pomocą operatora &.. Format komórki E9 posiada kategorię Ogólne.

6. W komórkach od A15 do H15 umieszczamy formuły, które pozwalają na pobieranie z komórki C9 kolejnych cyfr:

  • formuła dla komórki A15 — =FRAGMENT.TEKSTU(C9: l; 1),

  • formuła dla komórki B15 — =FRAGMENT.TEKSTU(C9;2:1),

  • formuła dla komórki C l5 — =FRAGMENT. TEKSTU (C9:3: l),

  • formuła dla komórki Dl5 — =FRAGMENT. TEKSTU (C9:4: l),

  • formuła dla komórki El5 — =FRAGMENT. TEKSTU (C9; 5; l),

  • formuła dla komórki F15 — =FRAGMENT. TEKSTU(C9; 7: l),

  • formuła dla komórki G15 — =FRAGMENT.TEKSTU(C9;8;1),

  • formuła dla komórki H15 — =FRAGMENT.TEKSTU(C9;9; 1)

Format komórek od A15 do H15 posiada kategorię Ogólne.

7. W komórkach od A10 do H16 umieszczamy formuły, które pozwalają na wyszukanie i pobieranie zawartości komórki z zakresu Al:Al0, której adres określa zawartość odpowiedniej komórki z wiersza 15 zwiększoną o l.

  • formuła dla komórki A16 — =INDEKS(Al:A10:A15+l),

  • formuła dla komórki B16 — =INDEKS(A1:A10;B15+1),

  • formuła dla komórki C165—=INDEKS(A1:A10;C15+1),

  • formuła dla komórki D16 —=INDEKS(A1:A10;D15+1),

  • formuła dla komórki E16 — =INDEKS(A1:A10; E15+1),

Format komórek od A16 do H16 posiada kategorię Ogólne

8. W komórce B18 należy wpisać formułę pozwalającą na sumowanie tekstowych zawartości komórek od A16 do H16, przy czym z uwagi na możliwość wystąpienia w nich komunikatu o błędzie (#ARG!) formuła powinna mieć następującą postać:

=JEŻELI(A15<>"";A16;"")&JEŻELI(B15<>"";B16;"")&JEŻELI(C15<>"";C16:"")&
JEŻELI(D15<>"":D16:"")&JEŻELI(E15<>"";E16;"")&JEŻELI(F15<>"":F16;"")&
JEŻELI(G15<>"";G16;'"')&JEŻELI(H15<>"";H16;"")&E9


Część II

Część druga prezentuje instrukcje wykonania zadania pt. Faktura VAT, które będzie dla Państwa podstawą zaliczenia laboratoriów z informatyki. Poniżej przedstawiona została kolejność działań oraz sposób i rodzaj danych, którymi wypełnicie Państwo konkretne komórki w poszczególnych arkuszach.


Faktura VAT

Przeznaczenie i budowa skoroszytu

Skoroszyt przeznaczony jest do wystawiania faktury VAT. Przedstawione poniżej rozwiązanie pozwala na operacje nieuwzględnione w szablonach faktur dostępnych w Excelu i należą do nich:

* zapis danych o towarach i usługach podlegających ustawie o podatku VAT lecz zwolnionych z jego naliczania,

* zapis słowny wartości faktury,

* wprowadzenie różnych stawek podatku VAT.

Skoroszyt składa się z sześciu arkuszy kalkulacyjnych, przeznaczonych do wykonywania następujących zadań:

1. Arkusz „NF”— nadawanie kolejnych numerów wystawianej fakturze.

2. Arkusz „Odbiorcy” — umożliwienie wyboru z bazy danych nazwy i adresu odbiorców.

3. Arkusz „Towary”— umożliwienie wyboru z bazy danych towarów podlegających sprzedaży.

4. Arkusz „Towary” — przygotowanie danych i wydruk gotowej faktury.

5. Arkusz „Dane firmy” — przechowywanie i udostępnianie nazwy wystawcy, tworzenie zapisów złożonego numeru faktury, miejsca i daty wystawienia oraz sprzedaży.

6. Arkusz „Słownie”— zmiana zapisu liczbowego wartości faktury na zapis słowny.

Szatę graficzną faktury przedstawiono na rysunku 2, przy czym w celach poglądowych w lewym górnym rogu faktury umieszczono znak graficzny wydawnictwa Helion, które zajmuje się oczywiście czymś innym niż sprzedażą towarów wyspecyfikowanych na fakturze.




Rysunek 2. Szata graficzna faktury

Arkusz „Dane firmy”

Pierwszą czynnością, jaką musimy wykonać, aby skoroszyt do wystawiania faktur spełnił nasze oczekiwania, jest prawidłowe przygotowanie (wypełnienie) arkusza „Dane firmy”. W celu ułatwienia identyfikacji komórek, które należy wypełnić, zostały one wypełnione kolorem jasnożółtym. Ich rozmieszczenie i początkowe wartości przedstawia rysunek 3.

Komórkami, w których znajdują się na stałe umieszczone „Dane firmy” i które nie ulegają zmianom w czasie tworzenia każdej faktury, nie będziemy zajmować się zbyt dokładnie. Wystarczy do nich raz wpisać odpowiednie dane zgodnie ze znajdującymi się obok nich opisami, a zostaną one każdorazowo umieszczone w części faktury zawierającej dane sprzedawcy. Szczegółowego omówienia wymagają natomiast pola faktury tworzone w sposób dynamiczny w zależności od dat, przyjętej zasady numerowania dokumentu oraz sposobu płatności.




Rysunek 3. Arkusz „Dane firmy”


Pola te zostały przedstawione na rysunku 4, a są nimi:

* pole numeru faktury— 1,

* pole miejsca i daty wystawienia faktury — 2,

* pole daty sprzedaży — 3,

* pole terminu płatności — 4,

* pole sposobu płatności — 5.



Rysunek 4. Komórki w arkuszu „ „ „Faktura””” powiązane z arkuszem „Dane firmy
Pole numeru faktury

Pole numeru faktury stanowi zawartość komórki E18, będąca wynikiem złożenia tekstów zawartych w komórkach G15,G16 i G17 arkusza „Dane firmy”. Realizuje je zawarta w niej formuła =G15&G16&G17.

Taki sposób tworzenia numeru faktury pozwala na uzyskanie dwóch schematów jego zapisu:

a) zapis w postaci — numer kolejny faktury/tekst/miesiąc/rok, np. 1572/DM/2/2003,

b) zapis w postaci — numer kolejny faktury/miesiąc/rok, np. 1572/2/2003. gdzie:

numer kolejny faktury to zawartość komórki G15 pobierana z arkusza „NF” (obsługa arkusza „NF” opisana w dalszej części),

tekst — tekst wprowadzany przez nas do komórki G16. W naszym przykładzie ma on postać ciągu znaków DM, co daje nam postać zapisu wymienioną w punkcie „a”. W przypadku wprowadzenia tylko znaku (/) otrzymamy postać zapisu z punktu „b”.

miesiąc/rok — ciąg znaków otrzymany przez zastosowanie w komórce G17 formuły =TEKST(G3;"m/rrrr"), powodującej zamianę zawartości komórki G3, przechowującej datę, na tekst zgodnie z podanym formatem mm/rrrr.

Pole miejsca i daty wystawienia faktury


Pole miejsca i daty wystawienia faktury stanowi zawartość komórki F4, będąca wynikiem złożenia tekstów zawartych w komórkach F3 i G3 arkusza „Dane firmy”.

Realizuje je zawarta w niej formuła =F3&TEKST(G3; "rrrr-mm-dd").

Zawartość komórki F3 wprowadzamy w postaci tekstu, np. Łódź, dnia. Zawartość komórki G3 jest pobierana z systemu przez zastosowanie w niej funkcji =DZIŚ( )+H3 i jest aktualizowana automatycznie przy każdym otwarciu skoroszytu. Aby mieć wpływ na jej wartość, np. wystawić fakturę z datą wcześniejszą lub późniejszą niż data systemowa bez potrzeby usuwania zapisu formuły z komórki, zastosowano dodatkową komórkę korekty H3, której zawartość jest dodawana do daty systemowej. Standardowo posiada ona zerową wartość (brak korekty). Wprowadzenie do niej cyfry, np. 3, spowoduje, że data wystawienia faktury będzie większa o trzy dni. Wprowadzenie wartości -3 ustawi datę o trzy dni wcześniej niż data systemowa (bieżąca), tak jak pokazano na rysunku 5. Korekta daty wystawienia faktury dokonana przez komórkę H3 powoduje automatycznie korektę daty sprzedaży (jeżeli przez korektę nastąpi zmiana miesiąca) oraz datę terminu płatności.



Rysunek 5. Ustawienia daty, fragment arkusza „Dane firmy”


Pole daty sprzedaży, wykonania usługi


Pole daty sprzedaży (wykonania usługi) stanowi zawartość komórki F7, będąca wynikiem zamiany daty wystawienia faktury zawartej w komórce G3 arkusza „Dane firmy” na postać tekstową z zastosowaniem formatowania tekstu według wzorca — mmmm rrrr. Realizuje je zawarta w niej formuła =TEKST(G3; "rrnnm rrrr"). Komórka aktualizowana automatycznie.

Pole termin płatności


Pole terminu płatności faktury stanowi zawartość komórki G10, będąca wynikiem dodawania daty z komórki G3 oraz liczby dni wprowadzonych przez nas do komórki G9 arkusza „Dane firmy”. W przypadku gdy termin płatności określimy na dwa tygodnie, do komórki G9 należy wpisać liczbę 14.

Pole sposób płatności


Pole sposobu płatności stanowi tekst przybierający jedną z postaci — GOTÓWKA, PRZELEW, CZEK, w zależności od wartości wprowadzonej przez nas do komórki G11 arkusza „Dane firmy”. Komórka G11 jest wyposażona w pole komentarza podpowiadającego, jaką wartość należy wprowadzić, by uzyskać żądany tekst.

Zamianę wartości na tekst realizuje zawarta w arkuszu Faktura komórka K18 za pomocą formuły:

=JEŻELI(„Danefirmy”!G11=1;"GOTÓWKA";"")&JEŻELI(„Danefirmy”!G11=2;
"PRZELEW";"")&JEŻELI( „Danefirmy”!G11=3;"CZEK";"").

Arkusz „NF”


Arkusz „NF” (rysunek 6) służy do półautomatycznego nadawania kolejnego numeru faktury. Zwrot półautomatycznego oznacza konieczność „pokazania skoroszytowi", że chcemy uzyskać następny numer faktury. W tym celu arkusz został wyposażony w dwa odpowiednio „oprogramowane" zakresy komórek. Jeden z nich to komórki C3:C600, w których przechowywany jest ostatni — aktywny — numer faktury, oraz zakres komórek B3:B600, do których wprowadzenie przez nas znaku X powoduje aktywację i udostępnienie następnego numeru faktury.



Rysunek 6. Arkusz „NF”

Ponadto w komórce B2 znajduje się numer początkowy, od którego (po jego zwiększeniu o wartość 1) rozpoczęła się numeracja dokumentów. Na obu wymienionych obszarach został założony autofiltr (widoczne dwa przyciski „strzałek" z prawej strony komórek B2 i C2) ułatwiający procedurę nadawania kolejnego numeru.

W celu nadania kolejnego numeru należy po aktywacji arkusza „NF” wykonać następujące czynności:

1. Kliknąć strzałkę autofiltru komórki C2, co spowoduje pokazanie się listy wyboru, jak na rysunku 7.



Rysunek 7. Lista wyboru numeru


2. Dokonać wyboru pozycji (Puste) przez kliknięcie na niej prawym przyciskiem myszy. Działanie to spowoduje przefiltrowanie obszaru komórek B3:C600 i przygotowanie pierwszego wolnego wiersza do aktualizacji — rysunek 8.



Rysunek 8. Widok przefiltrowanego obszaru komurek


3. Wpisać do pierwszego przefiltrowanego wiersza w kolumnie B znak X (wielkość litery dowolna), co spowoduje pokazanie się kolejnego numeru faktury w odpowiedniej komórce kolumny C (jak na rysunku 9).



Rysunek 9. Aktywacja nowego numeru faktury

Wygenerowany w ten sposób numer zostanie automatycznie pobrany do arkusza „Dane firmy” i zapisany w jego komórce G15, a następnie użyty do tworzenia ogólnego numeru faktury. Generowanie numeru w komórkach kolumny C jest możliwe przez zastosowanie w nich następującej formuły, np. dla komórkiB10

=JEŻELI(B10="x" ;$B$2+W!ERSZ()-1;"").

Taka konstrukcja arkusza do nadawania kolejnych numerów wystawianym fakturom umożliwia korzystanie tylko z jednego skoroszytu, przy czym zawsze mamy dostępną informację o ostatnim numerze wystawionego dokumentu.


Arkusz „Odbiorcy”

Arkusz „Odbiorcy” stanowi bazę kontrahentów (rysunek 10), za pomocą której możemy w szybki sposób umieścić — w części faktury określonej nabywca — wszystkie potrzeb­ne informacje, bez konieczności ich wpisywania za każdym razem, gdy tworzymy nowy dokument. Do budowy bazy wykorzystano następujące kolumny:

  • A — z etykietą Nazwa1,

  • B — z etykietą Nazwa2,

  • C — z etykietą Nazwa3,

  • D — z etykietą Miasto,

  • E — z etykietą Ulica,

  • F — z etykietą NIP,

  • G — kolumna podająca nr wiersza, w którym znajduje się pozycja
    ( formuła —=WIERSZ() ),

  • Komórka Hl zwraca numer wiersza wybranej pozycji przy zastosowaniu filtrowania ( formuła =SUMY.POŚREDNIE(9;G1:G200) ).




Rysunek 10. Wygląd arkusza Odbiorcy


Informacje dotyczące odbiorców wpisujemy zgodnie z etykietami kolumn. Wpisanie nazwy „Odbiorcy” powinniśmy tak rozplanować w kolumnach A, B i C, aby po jej wybraniu mieściła się w odpowiednich polach obszaru komórek H8:H10 arkusza Faktura. Do komórek kolumny Miasto wpisujemy nazwę miasta, w którym znajduje się siedziba „Odbiorcy”, poprzedzając ją jego kodem pocztowym. Nazwę ulicy (kolumna E) poprzedzamy skrótem ul..

W celu wybrania żądanego kontrahenta należy po otworzeniu arkusza „Odbiorcy” wykonać następujące czynności:

1. Kliknąć strzałkę autofiltru komórki Al, co spowoduje pokazanie się listy wyboru, jak na rysunku 11.




Rysunek 11. Aktywacja listy wyboru kolumny A


2. Dokonać wyboru pozycji przez kliknięcie na niej prawym przyciskiem myszy. Działanie to spowoduje przefiltrowanie obszaru komórek A2:G200 i wyświetlenie wybranego wiersza.

Do komórki Hl arkusza „Odbiorcy” wczytany zostanie numer wiersza, w którym znajduje się wybrana pozycja. Wygenerowany w ten sposób numer zostaje pobierany przez komórki arkusza „Faktura”, w których zapisywane są informacje dotyczące nazwy i adresu „Odbiorcy”. Jest to możliwe przez zastosowanie w nich następującej formuły, np. dla komórki H8 (arkusz „Faktura”)

=JEŻELI($K$12=1;INDEKS;Odbiorcy!A$l:A$200;Odbiorcy!$G$l);"").


Arkusz „Towary”


Arkusz „Towary” stanowi bazę towarów (materiałów), zawierającą niezbędne informacje do wystawienia faktury, bez konieczności ich wpisywania za każdym razem do arkusza „Faktura”. Ponieważ arkusz musi zapewniać możliwość wyspecyfikowania kilku (do 10) pozycji materiałowych, użycie techniki filtrowania (wyboru jednego z wielu) jest nieprzydatne. Rozwiązaniem pozwalającym na wybór kilku pozycji jest konstrukcja arkusza przedstawiona na rysunku 12. Składa się on z dwóch obszarów komórek:

  • obszar pierwszy — komórki B2:G11 — to obszar wyboru nazw towarów (materiałów) wraz z ich danymi dotyczącymi jednostki miary i ceny oraz pozycją (wierszem) zapisu w arkuszu „Towary”.

  • obszar drugi — komórki B13:F307 — to obszar rejestracji informacji o towarach (materiałach).




Rysunek 12. Wygląd arkusza “Towary”


Przygotowanie bazy towarowej (materiałowej)

Aby prawidłowo przygotować arkusz do eksploatacji, musimy dokonać zapisu całej naszej bazy towarowej (materiałowej) w obszarze komórek B13:C307 (w przypadku bazy o 5000 pozycjach będzie to oczywiście odpowiednio większy obszar — B13:C5012), zachowując pokazaną na rysunku 12 kolejność występowania informacji o towarze. Następnie tak stworzony obszar komórek musimy posortować w następujący sposób:

UWAGA ! ! !
dla potrzeb zadania zaliczeniowego proszę wpisać
do bazy produktów 200 pozycji


1. Zaznaczyć wiersze od numeru 12 do ostatniej wpisanej pozycji, a następnie z menu Dane wybrać polecenie Sortuj (jak na rysunku 13).

2. Po wykonaniu działania jak w punkcie 1. zostanie wywołane okno dialogowe Sortowanie (rysunek 14), w którym w sekcji „Sortuj według” wybieramy kolumnę B oraz sposób sortowania — Rosnąco, a następnie klikamy przycisk OK.

Wybór pozycji z bazy towarowej (materiałowej)

Obszar wyboru żądanych towarów (materiałów) zawiera komórki z zakresu B2:G11. Kolumny B, C i D służą do zapisu parametrów wybranego towaru, tzn. jego nazwy, użytej jednostki miary oraz ceny (rysunek 15).

Proces wyboru towaru (materiału) polega na wywołaniu w kolejnych komórkach kolumny B (B2, B3, B4... itd.) listy rozwijalnej przez:

  1. Naciśnięcie kombinacji klawiszy lewy „ALT+klawisz strzałki w dół” lub

  2. Otwarcie menu podręcznego (w aktywnej komórce kliknąć prawy przycisk myszy), a następnie wybór z menu polecenia „Wybierz z listy (rysunek 16).




Rysunek 13. Procedura sortowania




Rysunek 14. Okno dialogowe Sortowanie




Rysunek 15. Menu podręczne – wywołanie listy wyboru




Rysunek 16. Obszar wyboru towaru (materiałów)


Wykonanie czynności z punktu 1. lub 2. spowoduje udostępnienie listy nazw towarów, jak na rysunku 15, z której należy wybrać (kliknąć) żądaną pozycję. Formuła zapisana w komórkach G2:G11, np. dla komórki E2 mająca postać


=JEŻELI(B2<>"";PODAJ.POZYCJĘ($B2;B$12:BS307)+11;""),


identyfikuje numer wiersza, w którym zostały zapisane dane dotyczące wybranego towaru. Numer ten zostaje użyty do identyfikacji pozostałych parametrów towarów (materiałów), które są zapisywane odpowiednio np. w komórkach D2:D11 —jednostka miary lub E2:E11 — cena towaru (materiału).


Przy braku nazwy towaru w komórkach 62:616 (komórki puste) w odpowiadających im komórkach C2:C11, D2:D11, E2:E11 oraz F2:F11 występuje zapis błędu argumentu #ARG!, co stanowi prawidłową reakcję arkusza.

Arkusz Faktura

Arkusz Faktura stanowi praktycznie „zbiorcze zestawienie" danych zawartych w pozostałych arkuszach skoroszytu i jest przez nie automatycznie aktualizowany, co zapewniają odpowiednie formuły — odwołania.

W tabeli 1 zostały przedstawione podstawowe informacje dotyczące przeznaczenia (zawartości) komórek oraz zawartych w nich formuł, składających się na część nagłówkową faktury (rysunek 17).


Tabela 1. Opis komórek arkusza – część nagłówkowa faktury

Komórka
Przeznaczenie — zawartość

Formuła — odwołanie

J2

Pobiera miejsce i aktualną datę wystawienia faktury.

= Danefirmy!F4

G3

Pobiera kompletny numer faktury.

= Danefirmy!E18

J5

Pobiera datę sprzedaży towarów lub usługi.

= Danefirmy!F7

C8

Pobiera nazwę wystawiającego fakturę.

=Danefirmy!C2&ZNAKC(10)&Danefirmy!C3&
ZNAK(10)&„Dane firmy”!C4

C11

Pobiera adres wystawiającego fakturę.

= Danefirmy!C5&ZNAK(10)& Danefirmy!C6

D13

Pobiera numer NIP wystawiającego fakturę.

=Dane firmy!C7

D14

Pobiera Regon wystawiającego fakturę.

= Danefirmy!C10

C16

Pobiera nazwę banku właściwego dla wystawiającego fakturę.

= Dane firmy!C8

C 17

Pobiera numer konta wystawiającego fakturę.

= Danefirmy!C9

H8

Pobiera ,.nazwę 1" „Odbiorcy”.

=INDEKS(Odbiorcy!A$1:A$500;Odbiorcy!$H$1)

H9

Pobiera „nazwę 2" „Odbiorcy”.

=INDEKS(Odbiorcy!B$1:B$500;Odbiorcy!$H$1)

H10

Pobiera „nazwę 3" „Odbiorcy”.

-INDEKS(Odbiorcy!C$1:C$500;Odbiorcy!$H$1)

H11

Pobiera „miasto" „Odbiorcy”.

=INDEKS(Odbiorcy!D$1:D$500;Odbiorcy!$H$1)

H12

Pobiera „ulicę" „Odbiorcy”.

=INDEKS(Odbiorcy!E$1:E$500;Odbiorcy!$H$1)

I14

Pobiera Regon „Odbiorcy”.

=INDEKS(Odbiorcy!F$1:F$500;Odbiorcy!$H$1)

K17

Pobiera termin płatności faktury.

= Danefirmy!G10

K18

Pobiera rodzaj płatności.

=JEŻELI(Danefirmy!G11=1;"GOTÓWKA";"")&JEŻELI(Danefirmy!G11=2:"PRZELEW";”")&JEŻELI(Danefirmy”!G11=3;"CZEK";"")




Rysunek 17. Część nagłówkowa faktury


Oprócz funkcji pobierania odpowiednich danych, arkusz służy do wprowadzania ilości towarów i usług podlegających fakturowaniu oraz wykonywania niezbędnych obliczeń (wartości brutto). Obszar zawierający komórki przeznaczone do specyfikacji ilościowo-wartościowej towarów i usług został przedstawiony na rysunku 18, natomiast w tabeli 2 zostały przedstawione podstawowe informacje dotyczące przeznaczenia (zawartości) poszczególnych kolumn oraz przykłady zawartych w nich formuł.




Rysunek 18. Obszar specyfikacji ilościowo – wartościowej towarów i usług


Tabela 2. Opis komórek arkusza – część specyfikacji ilościowo – wartościowej towarów i usług

Komórki

Przeznaczenie — zawartość

Formuła — odwołanie

B24:B33

Automatyczne wstawienie liczby porządkowej.

Np. dla komórki B24

=JEŻELI($024<>"";"1.";””)

C24:C33

Pobranie nazw towarów (usług) z arkusza „Towary”.

Np. dla komórki C24

=JEŻELI($024<>"";Towary!B2;"")

F24:F33

Pobranie indeksu SWW towaru (usługi) z arkusza „Towary”.

Np. dla komórki F24

=JEŻELI($024<>"";Towary!C2;"")

G24:G33

Pobranie jednostki miary towarów (usług) z arkusza „Towary”.

Np. dla komórki G24

=JEŻELI($024<>"";Towary!D2;"")

H24:H33

Ilość towarów (usług).

wartość wprowadzana

124:133

Pobranie ceny jednostkowej towarów (usług) z arkusza „Towary”.

Np. dla komórki 124

=JEŻELI($024<>"";Towary!E2;"")

J24:J33

Wyliczenie wartość netto pozycji.

Np. dla komórki J24

=JEŻELI(H24<>"";H24*I24;"")

K24:K33

Pobranie stopy podatku VAT towarów (usług) z arkusza „Towary”.

Np. dla komórki K24

=JEŻELI($024<>"";Towary!F2;"")

L24:L33

Wyliczenie wartość podatku VAT dla pozycji.

Np. dla komórki 124

=JEŻELI(ORAZ(H24<>"";K24<>"zw");J24*(K24/100);"")

M24:M33

Wyliczenie wartość brutto pozycji.

Np. dla komórki M24

=JEŻELI(K24<>"";JEŻELI(K24="zw";J24;J24+L24);"")


Z obszarem specyfikacji ilościowo-wartościowej ściśle związany jest zakres komórek J35:M42, który na potrzeby niniejszego opisu nazwiemy sekcją podsumowań.

Sekcja ta zawiera komórki, w których umieszczone są:

  • sumy wartości brutto poszczególnych pozycji,

  • sumy wartości netto poszczególnych pozycji,

  • sumy podatku VAT w rozbiciu na poszczególne stawki podatkowe,

  • wartość łączna faktury.

W tabeli 3 zostały przedstawione podstawowe informacje dotyczące przeznaczenia (zawartości) komórek oraz zawartych w nich formuł, realizujących funkcję sumowań obszaru ilościowo-wartościowego faktury.


Tabela 3. Opis komórek arkusza – sekcja podsumowań

Komórka

Przeznaczenie — zawartość


Formuła — odwołanie

J35

Suma wartości netto


=SUMA($J$24:$J$33)

L35

Suma podatku VAT

=SUMA(L24:L33)

M35

Suma wartości brutto

=SUMA($M$24:$M$33)

J36

Suma wartości netto dla pozycji zwolnionych z podatku VAT

=SUMA.JEŻELI($K$24:$K$33;"=zw";$J$24:$J$33)

M36

Suma wartości brutto dla pozycji zwolnionych z podatku VAT

=SUMA.JEŻELI($K$24:$K$33;"=zw";$M$24:$M$33)

J 37

Suma wartości netto dla pozycji z 22% podatkiem VAT

=SUMA.JEŻELI($K$24:$K$33;"="&K37;$J24:$J33)

L37

Suma 22% podatku VAT

=SUMA.JEŻELI($K$24:$K$33;"="&K37:$L$24:$L$33)

M37

Suma wartości brutto dla pozycji z 22% podatkiem VAT

=SUMA.JEŻELI($K$24:$M$33;"="&K37;$M$24:$M$33)

J38

Suma wartości netto dla pozycji z 17% podatkiem VAT

=SUMA.JEŻELI($K$24:$K$33;"="&K38;$J24:$J33)

L38

Suma 1 7% podatku VAT

=SUMA.JEŻELI($K$24:$K$33;"="&K38;$L$24:$L$33)

M38

Suma wartości brutto dla pozycji z 17% podatkiem VAT

=SUMA.JEŻELI($K$24:$M$33;"="&K38:$M$24:$M$33)

J39

Suma wartości netto dla pozycji z 7% podatkiem VAT

=SUMA.JEŻELI($K$24:$K$33;"="&K39;$J$24:$J$33)

139

Suma 7% podatku VAT

=SUMA.JEŻELI($K$24:$K$33;"="&K39;$L$24:$L$33)

M39

Suma wartości brutto dla pozycji z 7% podatkiem VAT

=SUMA.JEŻELI($K$24:$M$33;"="&K39;$M$24:$M$33)

J40

Suma wartości netto dla pozycji z 3% podatkiem VAT

=SUMA.JEŻELI($K$24:$K$33;"="&K40:$J$24:SJS33)

140

Suma 3% podatku VAT

=SUMA.JEŻELI($K$24:$K$33;"="&K40;$L$24:$L$33)

M40

Suma wartości brutto dla pozycji z 3% podatkiem VAT

=SUMA.JEŻELI($K$24:$M$33;"="&K40:$M$24:$M$33)

J41

Suma wartości netto dla pozycji z 0% podatkiem VAT

=SUMA.JEŻELI($K$24:$K$33;"="&K41;$J24:$J$33)

L41

Suma 0% podatku VAT

=SUMA.JEŻELI($K$24:$K$33:"-"&K41:$L$24:$L$33)

M41

Suma wartości brutto dla pozycji z 0% podatkiem VAT

=SUMA.JEŻELI($K$24:$M$33;"-"&K41:$M$24:$M$33)

L42

Wartość faktury

=SUMA(M24:M33)


W opisywanym arkuszu wprowadzono (oprócz pozycji „zw”) pięć stawek podatku VAT. W przypadku potrzeby użycia innej stawki wystarczy zmienić w zakresie komórek K37:K47, stawkę która nie występuje w naszej fakturze na stawkę żądaną, a arkusz dokona automatycznie wyliczenia sum wartości netto, podatku i wartości brutto pozycji oznaczonych nową stawką. Umożliwiają to formuły, które nie zostały przypisane na „sztywno” do żadnej ze stawek podatkowych (oprócz pozycji „zw”).

Arkusz Słownie

Ostatnią modernizacją skoroszytu zawierającego formularz faktury jest stworzenie (lub wstawienie wcześniej przygotowanego) arkusza zamiany wyrażenia liczbowego na tekst opisanego we wcześniej przedstawionym przykładzie. Aby wartość z komórki L21 arkusza nazwanego w naszym przykładzie FAKTURA mogła być automatycznie zamieniana na tekst i wypisywana w komórce B17, należy wstawić następujące łącza:

  • w arkuszu FAKTURA jako formułę komórki B36 należy wpisać wyrażenie =słownie!B18, co jest odwołaniem do arkusza zamiany, który nazwaliśmy słownie,

  • w arkuszu słownie (rysunek 19) jako formułę komórki C8 należy wpisać wyrażenie =FAKTURA! L21, co jest odwołaniem do arkusza i komórki, z której będzie pobrana wartość liczbowa do zamiany




Rysunek 19. Widok arkusza SŁOWNIE z wstawionym łączem di arkusza FAKTURA


Inne operacje związane z budową arkusza

Ukrycie na fakturze zbędnych wartości zero

W sekcji podsumowań w pozycjach sum dotyczących poszczególnych stawek podat­kowych VAT pojawiają się zapisy wartości w postaci liczbowej 0,00, mimo że w sekcji specyfikacji nie wystąpił zapis towaru o takiej stawce podatkowej. Jest to spowodowane prawidłowym działaniem formuł i nie da się tego uniknąć. Możemy natomiast spowo­dować, że zera nie będą widoczne przez zmianę koloru czcionki z czarnego na biały. W tym celu musimy zastosować polecenie Formatowanie warunkowe. Aby wykonać wcześniej wspomniane polecenie, należy:

  1. Zaznaczyć zakres komórek poddanych formatowaniu, w naszym przypadku będą to dwa obszary, jeden to komórki z zakresu L24:M33, drugi obszar to komórki z zakresu J24:J33.

  2. Z menu Format wybrać polecenie Formatowanie warunkowe, co spowoduje aktywowanie okna Formatowanie warunkowe, jak na rysunku 10.20.



Rysunek 20. Okno formatowania warunkowego


  1. Ustawić w poszczególnych polach warunku parametry (tak jak na rysunku 20), tzn. w kolejności od lewej strony — Wartość komórki jest — równa — 0, a następnie nacisnąć przycisk Formatuj, co spowoduje pokazanie się okna Formatuj komórki, jak na rysunku 21.



Rysunek 21. Okno Formatuj komórki


  1. Na karcie Czcionka nacisnąć strzałkę przy liście rozwijalnej Kolor i z palety kolorów, która się ukaże, wybrać kolor biały, a następnie zamknąć okno, klikając przycisk OK.

  2. Nastąpi powrót do okna Formatowanie warunkowe, na którym również należy nacisnąć przycisk OK, co spowoduje zakończenie procedury formatowania warunkowego.

Procedurę formatowania należy przeprowadzić dla obu obszarów komórek wymienionych w punkcie 1. Nie formatować warunkowo obszarów, w których powinien występować zapis zera, np. w komórkach z zakresu K37:K41, gdyż pozbawi nas to możliwości uwidocznienia stawki 0 podatku VAT. Można również sformatować dodatkowo obszar komórek L24:L33 w sekcji specyfikacji, co zapobiegnie pokazywaniu zer w tej kolumnie dla stawek podatkowych 0 i „zw”, w których nie występuje kwota podatku VAT.


Powodzenia ! ! !




Dodaj dokument na swoim blogu lub stronie

Powiązany:

Zmiana zapisu wartości liczbowej na zapis słowny Przeznaczenie I budowa skoroszytu iconZależność całkowitego usunięcia jonu z roztworu od wartości liczbowej iloczynu rozpuszczalności soli strącającej się w postaci osadu

Zmiana zapisu wartości liczbowej na zapis słowny Przeznaczenie I budowa skoroszytu iconZmiana wartości jednostek uczestnictwa poszczególnych ofe

Zmiana zapisu wartości liczbowej na zapis słowny Przeznaczenie I budowa skoroszytu iconS t a n d a r d V. Zasady określania wartości szkód spowodowanych budową infrastruktury podziemnej I nadziemnej

Zmiana zapisu wartości liczbowej na zapis słowny Przeznaczenie I budowa skoroszytu iconS t a n d a r d V. Zasady określania wartości szkód spowodowanych budową infrastruktury podziemnej I nadziemnej

Zmiana zapisu wartości liczbowej na zapis słowny Przeznaczenie I budowa skoroszytu iconKomizm słowny w przysłowiach (priamelach). Definicja

Zmiana zapisu wartości liczbowej na zapis słowny Przeznaczenie I budowa skoroszytu iconPraca a zmiana energii. Czy zmiana energii jest miarą pracy?

Zmiana zapisu wartości liczbowej na zapis słowny Przeznaczenie I budowa skoroszytu iconCo to jest budowa ewolucyjna utworu? Budowa ewolucyjna utworu przypomina literacką prozę, czyli motywy I frazy następują po sobie łańcuchowo – jest to budowa rozwojowa

Zmiana zapisu wartości liczbowej na zapis słowny Przeznaczenie I budowa skoroszytu iconDział odpowiednik słowny uwagi 0 dział ogólny

Zmiana zapisu wartości liczbowej na zapis słowny Przeznaczenie I budowa skoroszytu iconKlasy I zadanie 1 (0-5 pkt.) Na osi liczbowej zilustruj zbiór tych liczb X, które spełniają nierówność

Zmiana zapisu wartości liczbowej na zapis słowny Przeznaczenie I budowa skoroszytu iconPrzeznaczenie

Umieść przycisk na swojej stronie:
Rozprawki


Baza danych jest chroniona prawami autorskimi ©pldocs.org 2014
stosuje się do zarządzania
Rozprawki
Dom