Word ćwiczenia 4




Pobierz 73.59 Kb.
NazwaWord ćwiczenia 4
Data konwersji16.10.2012
Rozmiar73.59 Kb.
TypDokumentacja

Word ćwiczenia 4



Korespondencja seryjna


Korespondencja seryjna to technika szybkiego tworzenia, różniących się tylko niektórymi elementami, szeregu identycznych dokumentów (seria), przy wykorzystania bazy adresowej np.: do drukowania kopert i etykiet itp.

Załóżmy, że musimy wysłać list identycznej treści do 100 różnych odbiorców. Np.: może to być zawiadomienie o zmianie numeru telefonu firmy, adresu itp. Word oferuje w tym względzie bardzo prosty mechanizm rozwiązania powyższego zadania. (Jeżeli dodatkowo dysponujemy pocztą elektroniczna i podamy e mailowy adres odbiorcy możemy informacje te wysłać bezpośrednio siecią).

Algorytm postępowania może być następujący:

  1. Tworzymy list, nazywany dalej dokumentem głównym (może to być aktualnie otwarty dokument worda). Np.:

W związku ze zmianą siedziby firmy podajemy nowy adres i nowy numer telefonu.

Za powstałe utrudnienia przepraszamy.

Z wyrazami szacunku,


AAAAA Sp.z o.o.

Prezes

  1. Tworzymy – jako nowy plik – lub otwieramy istniejąca bazę adresową. Może to być plik Worda (Excela, Accessa) w postaci tabeli:




Tytuł

Imię

Nazwisko

Instytucja

Ulica

Kod

Miejscowość

mgr

Alicja

Nowak

POLKOM

Agrestowa 4/5

66-009

Poznań

dr

Jerzy

Wąs

Sp. ABB

Wilcza 34/2A

00-001

Kraków
























Recordy (wiersze)

Dane (pola w recordach)

W przypadku tworzenia bazy adresowej w Wordzie, wiersz nagłówkowy tabeli musi koniecznie rozpoczynać się w pierwszym akapicie dokumentu. Po wprowadzeniu danych do tabeli (około 10 osób) zapisujemy plik pod nazwą baza adresowa i zamykamy go.

Każdy wiersz tabeli (oprócz nagłówkowego, który zawiera nazwy pól) stanowi jeden record. Dane w recordzie to tzw. pola, identyfikowane poprzez nazwę pola umieszczoną w pierwszym wierszu i numer recordu.

Jeżeli mamy gotowe te dwa elementy wywołujemy z menu Narzędzia polecenie Korespondencja seryjna. W zależności od tego czy wcześniej przygotowany został dokument główny czy też nie, pojawi się jedno z dwu pokazanych niżej okien dialogowych:



Wybieramy opcję: Pobierz dane i wskazujemy plik z bazą adresową. Następuje scalenie dokumentu głównego z bazą.

Przechodzimy do dokumentu głównego, w którym pojawi się nowy pasek narzędzi “Korespondencja seryjna”. Klikamy na pasku Wstaw pole korespondencji seryjnej. W rozwinięciu pojawią się nazwy pól, identyczne jak w pierwszym wierszu bazy adresowej:





Wstawiamy odpowiednie pola do dokumentu głównego i formatujemy je tak, jak zwykły tekst w Wordzie. Dokument może wygladać np. tak:

«Tytuł_naukowy»

«Imię» «NAZWISKO»

«Instytucja»

«ulica»

«Kod» «MIEJSCOWOŚĆ»

W związku ze zmianą siedziby firmy podajemy nowy adres i nowy numer telefonu.

Za powstałe utrudnienia przepraszamy.

Z wyrazami szacunku,


AAAAA Sp.z o.o.

Prezes

Po wybraniu opcji „Pokaż scalone dane” lub „Scalaj” Word pobiera odpowiednie dane z bazy. Np. dla recordu 1 dokument wygląda teraz tak:


Mgr

Alicja NOWAK

POLKOM

Agrestowa 4/5

66-009 POZNAŃ


W związku ze zmiana siedziby firmy podajemy nowy adres i nowy numer telefonu.

Za powstałe utrudnienia przepraszamy.

Z wyrazami szacunku,


AAAAA Sp.z o.o.

Prezes


Na tym etapie można właściwie zakończyć omawianie korespondecji seryjnej. Warto jednak rozszerzyć zakres wiedzy o użycie instrukcji sterujących, które zawiera pasek narzędzi „korespondencja seryjna





Wstawia w pozycji kursora pola z pliku danych (patrz wyżej)



Umieszcza w punkcie wstawienia instrukcję sterującą (omówione w dalszej części ćwiczenia)






Podgląd danych. Przełączanie cykliczne między widokiem dołączanych pól, a widokiem związanych z nimi danych.



Pierwszy record / Ostatni record. Przejście do pierwszego / ostatniego recordu zawartego w pliku danych.



Poprzedni / następny record. Przejście do poprzedniego / następnego recordu w bazie.



Idź do recordu. Przejście do recordu o wpisanym numerze.



Pomoc. Wyświetlane jest okno pomocy korespondencji seryjnej.



Sprawdź poprawność. Wyświetlane jest okno Sprawdzanie i raport błędów.



Scalaj w nowy dokument. Skierowanie wyniku łączenia dokumentów do oddzielnego (samodzielnego) pliku.



Scalaj na drukarkę. Skierowanie wyniku łączenia dokumentów na drukarkę.



KorSer. Wyświetlanie okna dialogowego Scalaj dane do ... (np. w celu dołączenia następnej bazy lub innego dokumentu)



Znajdź record. Wyświetlanie okna dialogowego znajdź record.



Edycja źródła danych. Wyświetlanie okna dialogowego Formularz danych (patrz niżej).





Omówimy krótko tylko niektóre (trudniejsze) polecenia a mianowicie: instrukcje sterujące scalaniem oraz sortowaniem i filtrowaniem danych. Instrukcje sterujące scalaniem są wyświetlane po rozwinięciu przycisku Wstaw pole programu Word

Instrukcje te pozwalają na różnicowanie łączonych dokumentów w zależności od zawartości poszczególnych recordów. W przypadku spełnienia podanego warunku można wstawić do dokumentu dodatkowe elementy. Instrukcje te wprowadza się do dokumentu poprzez wstawienie tzw. pól, które znacznie rozszerzają możliwości edytora (nie są to pola w znaczeniu jak używaliśmy ich w przypadku bazy, gdzie record składał się z pól, ale oddzielnymi elementami Worda).


Instrukcja

Działanie

Pytaj

Pyta o tekst, który ma być wprowadzony z klawiatury podczas scalania dokumentu w dowolnym jego miejscu. Np. w każdym egzemplarzu można wstawić odrębną kwotę do zapłaty itp. W tym celu ustawimy kursor w miejscu gdzie ma być wstawione pole Pytaj i wybieramy z menu górnego: Wstaw > Pole..>Pytaj (Ask).



Wypełnij

Instrukcja pozwala wprowadzić (podczas scalania) tylko do jednego dokumentu, określonego tekstu. Wstawianie do większej liczby dokumentów realizujemy za pomocą instrukcji Pytaj.



Jeżeli ... to ... w przeciwnym razie ...

Instrukcja ta pozwala zmienić sposób scalania dokumentu, w zależności od spełnienia warunku. Wstawiamy ją za pomocą polecenia Wstaw > pole ...



Nr scalanego recordu

Wstawia do dokumentu numer dołączanego recordu, będący numerem recordu w pliku z bazą danych.

Nr recordu w sekwencji

Jeżeli z dokumentem głównym łączymy recordy, które w pliku danych mają numery np. od 111 do 222 to przy dołączaniu pierwszego recordu z serii (czyli o numerze 111) instrukcja ta spowoduje wstawienie do dokumentu głównego numeru 1, record 112 będzie miał numer 2.itd

Następny record

Powoduje wstawienie do scalanego dokumentu następnego recordu z pliku danych.

Następny record jeśli ...

Powoduje wstawienie do scalanego dokumentu następnego recordu z pliku danych tylko wtedy gdy spełnia on podany warunek.

Przypisz zakładkę

Podobnie jak instrukcja Pytaj wstawiana jest zakładka jako pole dokumentu. Zakładka ma określoną wartość, która zostaje użyta we wszystkich scalanych dokumentach. Zakładkę można modyfikować, np. mając w perspektywie konieczność wielokrotnego przygotowywania informacji o różnych konferencjach możemy tylko zmieniać zakładkę (np. raz może to być Konferencja Ekologów, innym razem Konferencja Technologów), pozostawiając niezmieniony dokument główny.

Pomiń record jeśli ...

Powoduje pominięcie recordu do scalanego dokumentu i następuje przeskok do następnego recordu z pliku danych, wtedy gdy spełniony jest podany warunek.

Sortowanie i filtrowanie źródła danych – należy umieścić kursor w polu (kolumnie), według zawartości którego chcemy posortować dane. Następnie wybieramy jeden z przycisków: Sortuj od A do Z lub Sortuj od Z do A. Wybierając opcję Pomoc korespondencji seryjnej a następnie przycisk Opcje kwerend pojawi się okno dialogowe pozwalające na sortowanie bazy kolejno, według trzech wybranych kryteriów, np. nazwiska, imienia i tytułu naukowego:



Recordy można także filtrować tzn. wybierać tylko te, które spełniają podane kryteria. Jeżeli np. w bazie konferencji umieścimy pole „opłata konferencyjna” to możemy bardzo szybko zredagować i wysłać ponaglenie do osób, które jeszcze opłaty nie wniosły, lub gdy wniesiona kwota jest mniejsza od wymaganej =400 itp. – rys. poniżej



Opcje porównania:

WARUNEK

DZIAŁANIE

Równe

wybrane zostaną tylko recordy spełniające kryterium podane w polu Porównaj z:

Różne

wybrane zostaną tylko recordy nie spełniające kryterium podanego w polu Porównaj z:

Mniejsze / Większe

wybrane zostaną tylko recordy których wartość jest mniejsza (większa) niż podana w polu Porównaj z:

Mniejsze lub równe / Większe lub równe

wybrane zostaną tylko recordy których wartość jest mniejsza (większa) lub równa z wartością podaną w polu Porównaj z:

Puste

dołączane pole musi być puste (nie zawiera żadnych danych)

Niepuste

Dołączane pole nie może być puste

2.19.1. Przygotowanie do druku etykiet i kopert


Czynności te wykonujemy prawie identycznie jak w przypadku korespondencji seryjnej. Możemy także wykorzystywać istniejącą bazę adresową.

2.19.2. Drukowanie etykiet


Z paska narzędzi Korespondencja seryjna wybieramy pole Pomocnik korespondencji seryjnej, a następnie UtwórzEtykiety adresowe



Następnie tworzymy lub otwieramy plik danych. Po wybraniu przycisku Przygotuj dokument główny pojawi się okno dialogowe Opcje etykiet, w którym ustalamy typ drukarki i typ etykiet.



Po wybraniu odpowiedniej etykiety (lub jej samodzielnemu zdefiniowaniu w opcji Szczegóły) pojawi się okno Utwórz etykiety, w którym wstawiamy odpowiednie pola.



Przygotowany dokument może wyglądać następująco:



Po wybraniu przycisku następuje wypełnienie etykiet odpowiednimi danymi:



Drukowanie kopert – odbywa się identycznie jak drukowanie etykiet. Przetrenowanie tej opcji pozostawiono do samodzielnego wykonania.


Ćwiczenia do samodzielnego wykonania


Ćwiczenie 1

1. Utworzyć dokument będący bazą adresową w postaci następującej tabeli:

Tytuł naukowy

Imię

Nazwisko

Instytucja

ulica

Kod

miejscowość






















Tabela powinna zawierać min. 7 rekordów. Zapisać plik pod nazwą baza adresowa.

2. Utworzyć dokument główny zawierający tekst:

Uprzejmie informuję, że zgłoszony przez Pana/Panią artykuł został zakwalifikowany do druku. Wytyczne odnośnie formatu tekstu prześlemy pocztą.

Z poważaniem

3. Skojarzyć dokument główny z bazą adresową, wstawić odpowiednie pola z bazy. Postać gotowego dokumentu powinna być następująca:

Zielona Góra, 98.09.09

Prof.

Andrzej Kowalski

Politechnika Krakowska

Ul. Krasickiego 24

65-000 KRAKÓW


Uprzejmie informuję, że zgłoszony przez Pana/Panią artykuł został zakwalifikowany do druku. Wytyczne odnośnie formatu tekstu prześlemy pocztą.

Z poważaniem

4. Zmodyfikować dokument główny tak, aby wytłuszczone zostało nazwisko.

5. Zmodyfikować dokument główny i bazę adresową tak, aby:

w zależności od płci w dokumencie pojawiało się tylko słowa Pana lub tylko Pani;

dołożyć na początku słowo Szanowny lub Szanowna, ale tak aby Word automatycznie wybierał odpowiedni wyraz (lub końcówkę) w zależności od płci adresata.

6. Przygotować zestaw etykiet wykorzystując istniejącą bazę adresową.

7. Przygotować automatyczne drukowanie kopert wykorzystując istniejącą bazę adresową.

Ćwiczenie 2


Wykonaj dyplom według instrukcji ze strony: http://www.sp12tczew.hg.pl/publikacje/galant1/

Utwórz nowy dokument z baza danych, ma zawierać minimum 10 rekordów.


Ćwiczenie 3

Spróbuj przygotować zaproszenia na imprezę dla swoich bliskich przyjaciół. Stwórz dwa dokumenty: zaproszenie i listę adresów przyszłych gości. Użyj pomocnika korespondencji seryjnej do wstawiania odpowiednich pól do twojego zaproszenia, po czym scal ten dokument z listą danych. Nie zapomnij również o stworzeniu etykiet adresowych na koperty.

Podsumowanie:
 


Aby:

Należy:

Stworzyć źródło danych

Wstawić tabelę z dowolną, potrzebną liczbą kolumn. W pierwszym wierszu umieść nazwy pól, pozostałe wiersze tabeli wypełnij danymi.
Pamiętaj! Pierwszy wiersz dokumentu powinien zawierać nazwy pól. Zapisz stworzone źródło danych.

Stworzyć dokument główny i powiązać go ze źródłem danych

Z menu "Narzędzia" wybrać pozycję "Korespondencja seryjna". Kliknij przycisk "Utwórz" i wybierz z menu pozycję "Listy seryjne". Wciśnij przycisk "Aktywne okno", jeśli oczywiście chcesz korzystać z dokumentu widocznego na ekranie. Kliknij przycisk "Pobierz dane" i z listy wybierz pozycję "Otwórz" źródło danych. Z listy plików wybierz dokument, który ma być źródłem danych.

Wstawić pola korespondencji seryjnej do dokumentu głównego

Dokument główny powinien być widoczny na ekranie. Wciśnij przycisk "Wstaw pole korespondencji seryjnej" na pasku narzędzi "Korespondencja seryjna". Kliknij nazwy tych pól, które chciałbyś wstawić do dokumentu.

Scalić dokument główny ze źródłem danych

Dokument główny powinien być widoczny na ekranie. Wciśnij przycisk "Scal do nowego dokumentu" znajdujący się w pasku narzędzi "Korespondencja seryjna".

Dodaj dokument na swoim blogu lub stronie

Powiązany:

Word ćwiczenia 4 iconWord Ćwiczenia 7

Word ćwiczenia 4 iconWord ćwiczenia 1 zadanie 1

Word ćwiczenia 4 iconWord – Ćwiczenia 2 I. Tabulatory

Word ćwiczenia 4 iconĆwiczenia praktyczne z edytora tekstu word

Word ćwiczenia 4 iconEdytor tekstowy Word 17. Tabulatory Ćwiczenia

Word ćwiczenia 4 iconInstrukcja do Ćwiczenia „Edytor tekstu ms word 2007 I nie tylko

Word ćwiczenia 4 iconKurs word: podstawowe opcje (mała ściąga) Temat 1: Główne okno ms word

Word ćwiczenia 4 iconKurs word: podstawowe opcje (mała ściąga) Temat 1: Główne okno ms word

Word ćwiczenia 4 icon1. Otwórz program Word: Start – Programy – Word I napisz u góry tytuł: „Kolorowa choinka” czcionka Arial

Word ćwiczenia 4 iconCel ćwiczenia Celem ćwiczenia jest poznanie zasady działania I obsługi wybranych mierników cyfrowych. Program ćwiczenia

Umieść przycisk na swojej stronie:
Rozprawki


Baza danych jest chroniona prawami autorskimi ©pldocs.org 2014
stosuje się do zarządzania
Rozprawki
Dom